Bug 146202

Summary: REGRESSION(r182303): [GTK] Context menu API is broken since r182303
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: berto, commit-queue, csaavedra, gns, mcatanzaro, mrobinson, pnormand, svillar
Priority: P2 Keywords: Gtk
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch zan: review+

Description Carlos Garcia Campos 2015-06-22 05:06:27 PDT
And we didn't notice it because context menu API tests are skipped (see https://bugs.webkit.org/show_bug.cgi?id=117689). The problem is that ContextMenuclient API changed in r182303, but we didn't notice it either, and the default handler for getContextMenuFromProposedMenu was executed. An override keyword would have caught this.
Comment 1 Carlos Garcia Campos 2015-06-22 05:08:44 PDT
Created attachment 255343 [details]
Patch
Comment 2 WebKit Commit Bot 2015-06-22 05:10:46 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Carlos Garcia Campos 2015-06-22 05:43:26 PDT
Committed r185825: <http://trac.webkit.org/changeset/185825>