Bug 145949

Summary: AX:ARIA Toggle buttons aren't properly conveyed on iOS using VoiceOver
Product: WebKit Reporter: chris fleizach <cfleizach>
Component: AccessibilityAssignee: chris fleizach <cfleizach>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: aboxhall, apinheiro, buildbot, commit-queue, dmazzoni, jcraig, jdiggs, mario, rniwa, samuel_white, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
patch
buildbot: commit-queue-
Archive of layout-test-results from ews103 for mac-mavericks
none
Archive of layout-test-results from ews106 for mac-mavericks-wk2
none
patch darin: review+

Description chris fleizach 2015-06-12 16:59:00 PDT
We need to expose some attributes to the platform API to decide if an element has a pressed state.
Comment 1 chris fleizach 2015-06-12 16:59:15 PDT
<rdar://problem/19073512>
Comment 2 chris fleizach 2015-06-12 17:00:59 PDT
Created attachment 254835 [details]
patch
Comment 3 Build Bot 2015-06-12 17:36:00 PDT
Comment on attachment 254835 [details]
patch

Attachment 254835 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/6203648069599232

New failing tests:
inspector-protocol/dom/getAccessibilityPropertiesForNode.html
Comment 4 Build Bot 2015-06-12 17:36:04 PDT
Created attachment 254838 [details]
Archive of layout-test-results from ews103 for mac-mavericks

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews103  Port: mac-mavericks  Platform: Mac OS X 10.9.5
Comment 5 Build Bot 2015-06-12 17:39:55 PDT
Comment on attachment 254835 [details]
patch

Attachment 254835 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/5791548105031680

New failing tests:
inspector-protocol/dom/getAccessibilityPropertiesForNode.html
Comment 6 Build Bot 2015-06-12 17:39:59 PDT
Created attachment 254839 [details]
Archive of layout-test-results from ews106 for mac-mavericks-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews106  Port: mac-mavericks-wk2  Platform: Mac OS X 10.9.5
Comment 7 chris fleizach 2015-06-12 18:06:00 PDT
*** Bug 129830 has been marked as a duplicate of this bug. ***
Comment 8 chris fleizach 2015-06-12 18:07:56 PDT
Created attachment 254842 [details]
patch
Comment 9 Darin Adler 2015-06-12 18:41:35 PDT
Comment on attachment 254842 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=254842&action=review

> Source/WebCore/accessibility/AccessibilityObject.cpp:2221
> +    if (equalIgnoringCase(expanded, "true") || equalIgnoringCase(expanded, "false"))
> +        return true;
> +    return false;

Should just be:

    return equalIgnoringCase(expanded, "true") || equalIgnoringCase(expanded, "false");
Comment 10 James Craig 2019-09-26 11:52:20 PDT
Chris, rdar://19073512 was resolved in 2015. Anything left to do here?
Comment 11 chris fleizach 2019-09-26 11:54:46 PDT
(In reply to James Craig from comment #10)
> Chris, rdar://19073512 was resolved in 2015. Anything left to do here?

ha, what happened with this bug. yea it looks like there's code that solves this, but not from this patch directly.