Bug 145116

Summary: Rename createIterResultObject as createIteratorResultObject
Product: WebKit Reporter: youenn fablet <youennf>
Component: JavaScriptCoreAssignee: youenn fablet <youennf>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, darin
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch for landing none

Description youenn fablet 2015-05-17 23:40:04 PDT
Following on bug 144790 first review, it might be good to rename createIterResultObject as createIteratorResultObject before starting using it in WebCore.
Comment 1 youenn fablet 2015-05-18 01:49:08 PDT
Created attachment 253311 [details]
Patch
Comment 2 WebKit Commit Bot 2015-05-18 01:51:10 PDT
Attachment 253311 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/runtime/IteratorOperations.h:34:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/runtime/IteratorOperations.h:40:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 2 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 youenn fablet 2015-05-18 08:09:06 PDT
Comment on attachment 253311 [details]
Patch

Latest patch for bug 144790 makes uses of this renamed and newly exported method.
See https://bugs.webkit.org/attachment.cgi?id=253325&action=review
Comment 4 Darin Adler 2015-05-19 08:55:08 PDT
Comment on attachment 253311 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=253311&action=review

> Source/JavaScriptCore/runtime/IteratorOperations.h:34
> -JSValue iteratorNext(ExecState*, JSValue iterator, JSValue);
> +JSValue iteratorNext(ExecState*, JSValue iterator, JSValue value);

I agree with the style bot, the word "value" here is not specific enough to be helpful. I’m OK with adding an argument name here, but not sure what it would be.

> Source/JavaScriptCore/runtime/IteratorOperations.h:37
>  JSValue iteratorValue(ExecState*, JSValue iterResult);
>  bool iteratorComplete(ExecState*, JSValue iterResult);

Should give iterResult a better name.

> Source/JavaScriptCore/runtime/IteratorOperations.h:40
> +JS_EXPORT_PRIVATE JSObject* createIteratorResultObject(ExecState*, JSValue value, bool done);

I agree with the style bot, the word "value" here is not specific enough to be helpful. I’m OK with adding an argument name here, but not sure what it would be.
Comment 5 youenn fablet 2015-05-19 12:45:15 PDT
Comment on attachment 253311 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=253311&action=review

>> Source/JavaScriptCore/runtime/IteratorOperations.h:34
>> +JSValue iteratorNext(ExecState*, JSValue iterator, JSValue value);
> 
> I agree with the style bot, the word "value" here is not specific enough to be helpful. I’m OK with adding an argument name here, but not sure what it would be.

OK, let's remove it.

>> Source/JavaScriptCore/runtime/IteratorOperations.h:37
>>  bool iteratorComplete(ExecState*, JSValue iterResult);
> 
> Should give iterResult a better name.

OK, renaming it to iterator.
Comment 6 youenn fablet 2015-05-19 12:46:54 PDT
Created attachment 253391 [details]
Patch for landing
Comment 7 WebKit Commit Bot 2015-05-19 13:08:04 PDT
Comment on attachment 253391 [details]
Patch for landing

Clearing flags on attachment: 253391

Committed r184586: <http://trac.webkit.org/changeset/184586>
Comment 8 WebKit Commit Bot 2015-05-19 13:08:08 PDT
All reviewed patches have been landed.  Closing bug.