Bug 144978

Summary: Make a class that replaces 'typedef ... IdentifierSet' which encapsulates lexical identifier semantics
Product: WebKit Reporter: Saam Barati <saam>
Component: JavaScriptCoreAssignee: Saam Barati <saam>
Severity: Normal CC: benjamin, fpizlo, ggaren, mark.lam, mmirman, msaboff, oliver
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 142944    
Bug Blocks:    

Description Saam Barati 2015-05-13 18:10:31 PDT
This will allow us to:
- pass around one variable instead of having two variables where one represents identifiers, and one represents captured identifiers.
  This adds to the overall cleanliness of the code and abstracts this stuff away.
- Associate identifiers with flags. Specifically, indicating if a variable is a constant or not.
Comment 1 Saam Barati 2015-07-02 14:01:41 PDT
Now being rolled into:

*** This bug has been marked as a duplicate of bug 142944 ***