Bug 143168

Summary: load8Signed() and load16Signed() should be renamed to avoid confusion
Product: WebKit Reporter: Michael Saboff <msaboff>
Component: JavaScriptCoreAssignee: Michael Saboff <msaboff>
Severity: Normal    
Priority: P2    
Version: 312.x   
Hardware: All   
OS: All   
Description Flags
Patch for lnding, already reviewed. none

Description Michael Saboff 2015-03-27 17:53:15 PDT
It isn't clear from the names of the JSC MacroAssembler function load8Signed() and load16Signed() as to how many bits to sign extend.  The code expects sign extending to 32 bits, but the ARM64 version was sign extending to 64 bits (https://bugs.webkit.org/show_bug.cgi?id=138390).  The names of these function should reflect the number of bits they sign extend out to.
Comment 1 Michael Saboff 2015-03-27 17:57:40 PDT
Created attachment 249627 [details]
Patch for lnding, already reviewed.
Comment 2 Michael Saboff 2015-03-27 19:55:54 PDT
Committed r182098: <http://trac.webkit.org/changeset/182098>