Bug 142291

Summary: [GTK] Some layout tests are failing since r180924
Product: WebKit Reporter: Marcos Chavarría Teijeiro (irc: chavaone) <chavarria1991>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: cgarcia, chavarria1991
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Marcos Chavarría Teijeiro (irc: chavaone) 2015-03-04 09:52:48 PST
The following layout test are failing since r180924 (http://trac.webkit.org/changeset/180924):

fast/regions/repaint/region-painting-in-composited-view.html -> https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r180999%20%286665%29/fast/regions/repaint/region-painting-in-composited-view-diffs.html
transforms/2d/perspective-not-fixed-container.html -> https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r180999%20%286665%29/transforms/2d/perspective-not-fixed-container-diffs.html
transforms/hittest-translated-content-off-to-infinity-and-back.html -> transforms/hittest-translated-content-off-to-infinity-and-back
css3/calc/transforms-translate.html -> https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r180999%20%286665%29/css3/calc/transforms-translate-diffs.html
fast/clip/clip-when-rect-has-fractional-pixel-value.html -> https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r180999%20%286665%29/fast/clip/clip-when-rect-has-fractional-pixel-value-diffs.html
fast/layers/no-clipping-overflow-hidden-hardware-acceleration.html -> https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r180999%20%286665%29/fast/layers/no-clipping-overflow-hidden-hardware-acceleration-diffs.html
fast/regions/repaint/fixed-in-named-flow-cb-changed.html -> https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r180999%20%286665%29/fast/regions/repaint/fixed-in-named-flow-cb-changed-diffs.html
Comment 1 Carlos Garcia Campos 2015-03-04 23:15:09 PST
There might be a problem with the web view size not correctly propagated to the web process when the web process is in AC mode, but the web view hasn't been realized yet. I'll look at it.
Comment 2 Carlos Garcia Campos 2015-03-05 02:27:17 PST
Found 7 tests; running 7, skipping 0.
Running 6 WebKitTestRunners in parallel.

[6/7] fast/clip/clip-when-rect-has-fractional-pixel-value.html passed unexpectedly
[6/7] fast/regions/repaint/fixed-in-named-flow-cb-changed.html passed unexpectedly
[7/7] fast/layers/no-clipping-overflow-hidden-hardware-acceleration.html passed unexpectedly
[7/7] transforms/2d/perspective-not-fixed-container.html passed unexpectedly
[7/7] fast/regions/repaint/region-painting-in-composited-view.html passed unexpectedly

2 tests ran as expected, 5 didn't:


Expected to fail, but passed: (5)
  fast/clip/clip-when-rect-has-fractional-pixel-value.html
  fast/layers/no-clipping-overflow-hidden-hardware-acceleration.html
  fast/regions/repaint/fixed-in-named-flow-cb-changed.html
  fast/regions/repaint/region-painting-in-composited-view.html
  transforms/2d/perspective-not-fixed-container.html

I can't reproduce the issues :-(
Comment 3 Marcos Chavarría Teijeiro (irc: chavaone) 2015-03-09 02:22:55 PDT
Revision r181138 (http://trac.webkit.org/changeset/181138) seems to fix most of these issues. I have to take a look at it.
Comment 4 Marcos Chavarría Teijeiro (irc: chavaone) 2015-03-13 02:50:29 PDT
This test are passing after r181138.

Updating Test Expectations on https://bugs.webkit.org/show_bug.cgi?id=142665.