|Summary:||_actionMenuItemsForHitTestResult should also take a type indicating what the menu was built for|
|Product:||WebKit||Reporter:||Beth Dakin <bdakin>|
|Severity:||Normal||CC:||bdakin, conrad_shultz, mitz, thorton|
|Version:||528+ (Nightly build)|
Description Beth Dakin 2014-10-24 16:25:07 PDT
_actionMenuItemsForHitTestResult should also take a type indicating what the menu was built for since HitTestResults that are both images and links could go either way.
Comment 2 Beth Dakin 2014-10-24 16:40:28 PDT
Created attachment 240446 [details] Patch v2 Oopsie, that wasn't quite right. This one should do it.
Comment 3 mitz 2014-10-24 16:44:31 PDT
Comment on attachment 240446 [details] Patch v2 View in context: https://bugs.webkit.org/attachment.cgi?id=240446&action=review > Source/WebKit2/Shared/API/c/WKActionMenuTypes.h:40 > +typedef uint32_t WKActionMenuType; Can you give this an underscore prefix in case we ever want to use this name for something in the modern API? > Source/WebKit2/UIProcess/mac/WKActionMenuController.mm:68 > + Extra newline.