Bug 135885

Summary: [EFL] Bump up and patch dependencies to allow building for aarch64
Product: WebKit Reporter: Akos Kiss <akiss>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, gyuyoung.kim, ossy
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 108645    
Attachments:
Description Flags
Proposed patch. none

Description Akos Kiss 2014-08-13 09:40:25 PDT
The tarball releases of pixman 0.24.0, libffi 3.0.11, glib 2.38.0, glib-networking 2.33.2, and fontconfig 2.8.0 don't configure for aarch64. Gstreamer-plugins-base 1.2.1 configures for aarch64 but recognizes NEON support incorrectly and fails during the build later on. For WebKitEfl to build on aarch64, these libraries need to be bumped up/patched.
Comment 1 Akos Kiss 2014-08-13 09:49:37 PDT
Created attachment 236531 [details]
Proposed patch.
Comment 2 Gyuyoung Kim 2014-08-13 19:18:29 PDT
Comment on attachment 236531 [details]
Proposed patch.

Awesome ! Do you have a plan to attach an aarch64 buildbot for EFL port ?
Comment 3 WebKit Commit Bot 2014-08-13 19:52:38 PDT
Comment on attachment 236531 [details]
Proposed patch.

Clearing flags on attachment: 236531

Committed r172549: <http://trac.webkit.org/changeset/172549>
Comment 4 WebKit Commit Bot 2014-08-13 19:52:40 PDT
All reviewed patches have been landed.  Closing bug.