Bug 135712

Summary: Fixed backgrounds don't paint in blurred inset areas
Product: WebKit Reporter: Beth Dakin <bdakin>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bdakin, commit-queue, esprehn+autocc, glenn, kondapallykalyan, simon.fraser, thorton
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 135748    
Bug Blocks: 147049    
Attachments:
Description Flags
For review
none
Patch with test
none
Patch
simon.fraser: review+
Patch simon.fraser: review+

Description Beth Dakin 2014-08-07 13:09:53 PDT
Background images that are background-attachment:fixed fail to paint in blurred inset areas.

<rdar://problem/17848141>
Comment 1 Beth Dakin 2014-08-07 13:17:31 PDT
Created attachment 236213 [details]
For review
Comment 2 Beth Dakin 2014-08-07 14:34:32 PDT
Created attachment 236225 [details]
Patch with test
Comment 3 Beth Dakin 2014-08-07 15:12:47 PDT
Created attachment 236233 [details]
Patch

The previous test did not work in wk2. Here's a new patch.
Comment 4 Beth Dakin 2014-08-07 15:25:50 PDT
Thanks Simon! http://trac.webkit.org/changeset/172291
Comment 5 WebKit Commit Bot 2014-08-07 23:37:39 PDT
Re-opened since this is blocked by bug 135748
Comment 6 Tim Horton 2014-08-07 23:45:59 PDT
With this patch, background-attachment: fixed on <body> with top content inset applied in WebKit2 ends up with a weird, large band of color at the top.
Comment 7 Beth Dakin 2014-08-11 15:44:13 PDT
Created attachment 236409 [details]
Patch
Comment 8 Beth Dakin 2014-08-11 15:45:30 PDT
This patch fixes the regression caused by the original patch and adds an additional test to confirm that.
Comment 9 Beth Dakin 2014-08-11 16:04:20 PDT
Thanks Simon! http://trac.webkit.org/changeset/172417