Bug 13460

Summary: Scrollbars for short height elements (multitext, list and other elements)
Product: WebKit Reporter: Kanda <kanda>
Component: FormsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Major CC: ap
Priority: P2    
Version: 523.x (Safari 3)   
Hardware: Macintosh   
OS: OS X 10.4   
Attachments:
Description Flags
Issue with the scroll bar on UI Elements none

Description Kanda 2007-04-23 15:52:37 PDT
Safari requires a minimum height of 56 pixels to draw a functioning scrollbar on divs or textareas. So if your code and the users settings produce a smaller box (e.g. rows=4 & default settings), no scrollbar will appear no matter how many lines the user enters. On the list element, no matter how many list entries are there, the scroll bars won't show up because the list height is less than 56 pixels. This will be frustrating to the users.
Comment 1 Alexey Proskuryakov 2007-04-23 21:23:06 PDT

*** This bug has been marked as a duplicate of 5005 ***
Comment 2 Kanda 2007-05-24 11:21:07 PDT
Safari requires a minimum height of 56 pixels to draw a functioning scrollbar
on divs or textareas. So if your code and the users settings produce a smaller
box (e.g. rows=4 & default settings), no scrollbar will appear no matter how
many lines the user enters. On the list element, no matter how many list
entries are there, the scroll bars won't show up because the list height is
less than 56 pixels. This will be frustrating to the users.
Comment 3 Alexey Proskuryakov 2007-05-24 21:57:09 PDT
Reporter, you have reopened this bug - could you please explain why?
Comment 4 David Kilzer (:ddkilzer) 2007-05-24 22:44:29 PDT
(In reply to comment #3)
> Reporter, you have reopened this bug - could you please explain why?

See Comment #2?

Comment 5 Alexey Proskuryakov 2007-05-25 01:40:30 PDT
No, comment 2 is identical to comment 0.
Comment 6 Kanda 2007-05-25 11:10:40 PDT
Created attachment 14727 [details]
Issue with the scroll bar on UI Elements
Comment 7 Kanda 2007-05-25 11:11:07 PDT
Summary: 
Scrollbars for short height elements (multitext, list and other elements)


Steps to Reproduce: 
1. Create HTML form with scrolling div with height of 140 pixels or less.
2. Access HTML form in Safari or latest version of WebKit
3. Enter enough data into the div you created in step 1 forcing the div to scroll.


Expected Results: 
Scrollbar should be actionable and allow the user to scroll the content. 


Actual Results: 
Scrollbar is not actionable and doesn't allow the user to interact with it. The user can NOT scroll the content. 


Regression: 
Anytime the scroll height is less than 140 pixes.


Notes: 
See screen shot.
Comment 8 Alexey Proskuryakov 2007-05-26 02:54:27 PDT
Reporter, please explain how this is different from bug 5005.
Comment 9 Alexey Proskuryakov 2007-06-23 06:56:23 PDT
The description matches what we already track as bug 5005; closing as a duplicate again. Please don't re-open unless you think there is some important difference between these bugs.

*** This bug has been marked as a duplicate of 5005 ***