Bug 134097

Summary: REGRESSION(r170163): It made everything crash on EFL
Product: WebKit Reporter: Zsolt Borbely <zsborbely.u-szeged>
Component: WebKit EFLAssignee: Gyuyoung Kim <gyuyoung.kim>
Status: RESOLVED FIXED    
Severity: Critical CC: gyuyoung.kim, gyuyoung.kim, koivisto, lucas.de.marchi, ossy, simon.fraser
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 134073    
Attachments:
Description Flags
Patch none

Description Zsolt Borbely 2014-06-20 01:00:55 PDT
Running Animation/balls.html (1 of 139)
error: Animation/balls.html
1   0x7f1625e21bf0
2   0x7f16261afff0
3   0x7f1626864446 WebKit::WebPage::didCompletePageTransition()
4   0x7f1626842e26 WebKit::WebFrameLoaderClient::frameLoadCompleted()
5   0x7f162447b409 WebCore::FrameLoader::frameLoadCompleted()
6   0x7f162447b495 WebCore::FrameLoader::setState(WebCore::FrameState)
7   0x7f162447fa25 WebCore::FrameLoader::checkLoadCompleteForThisFrame()
8   0x7f162447fe03 WebCore::FrameLoader::checkLoadComplete()
9   0x7f162447ffa2 WebCore::FrameLoader::checkCompleted()
10  0x7f162447ae95 WebCore::FrameLoader::init()
11  0x7f162685d47f WebKit::WebFrame::createWithCoreMainFrame(WebKit::WebPage*, WebCore::Frame*)
12  0x7f1626871b45 WebKit::WebPage::WebPage(unsigned long, WebKit::WebPageCreationParameters const&)
13  0x7f162687213f WebKit::WebPage::create(unsigned long, WebKit::WebPageCreationParameters const&)
14  0x7f16267eff25 WebKit::WebProcess::createWebPage(unsigned long, WebKit::WebPageCreationParameters const&)
15  0x7f16268f487e WebKit::WebProcess::didReceiveWebProcessMessage(IPC::Connection*, IPC::MessageDecoder&)
16  0x7f16266f86b4 IPC::Connection::dispatchMessage(std::unique_ptr<IPC::MessageDecoder, std::default_delete<IPC::MessageDecoder> >)
17  0x7f16266f8814 IPC::Connection::dispatchOneMessage()
18  0x7f1626902ce3 WTF::RunLoop::performWork()
19  0x7f16226fb2de
20  0x7f16226fba66
21  0x7f16226faa91
22  0x7f16226fac97 ecore_main_loop_begin
23  0x7f16268d3fa9 int WebKit::ChildProcessMain<WebKit::WebProcess, WebKit::WebProcessMain>(int, char**)
24  0x7f162619ade5 __libc_start_main
25  0x4007c3

FAILED
Finished: 0.726421 s
Comment 1 Gyuyoung Kim 2014-06-20 01:53:55 PDT
AFAIK, m_mainFrame is null in WebPage::didCompletePageTransition() since r170163. So, if we simply add a null checking code as below, it looks EFL port is fine. However, we need to investigate r170163 further to sync with EFL port.


void WebPage::didCompletePageTransition()
{
#if USE(TILED_BACKING_STORE)
    if (m_mainFrame && m_mainFrame->coreFrame()->view()->delegatesScrolling())
        // Wait until the UI process sent us the visible rect it wants rendered.
        send(Messages::WebPageProxy::PageTransitionViewportReady());
    else
#endif
        
    m_drawingArea->setLayerTreeStateIsFrozen(false);
}
Comment 2 Csaba Osztrogon√°c 2014-06-20 01:56:12 PDT
It seems not only perf tests, but layout tests crash too - http://build.webkit.org/builders/EFL%20Linux%2064-bit%20Release%20WK2/builds/15217
Comment 3 Gyuyoung Kim 2014-06-20 22:26:42 PDT
Created attachment 233508 [details]
Patch
Comment 4 Gyuyoung Kim 2014-06-22 19:27:21 PDT
Committed r170279: <http://trac.webkit.org/changeset/170279>
Comment 5 Antti Koivisto 2014-06-24 00:38:14 PDT
Comment on attachment 233508 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=233508&action=review

> Source/WebKit2/WebProcess/WebPage/WebPage.cpp:2268
> +    // m_mainFrame can be null since r170163.

Comments like this are not useful.
Comment 6 Gyuyoung Kim 2014-06-24 00:40:02 PDT
(In reply to comment #5)
> (From update of attachment 233508 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=233508&action=review
> 
> > Source/WebKit2/WebProcess/WebPage/WebPage.cpp:2268
> > +    // m_mainFrame can be null since r170163.
> 
> Comments like this are not useful.

I see. I will not use similar comment in next time. Do you want to remove it now ?