Bug 134068

Summary: Web Inspector: Esc in quick console no longer toggles console drawer
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: Web InspectorAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, graouts, joepeck, jonowells, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
[PATCH] Proposed Fix none

Description Joseph Pecoraro 2014-06-19 12:18:03 PDT
Regression. Pushing Esc in the quick console no longer toggles the console drawer. It should!
Comment 1 Joseph Pecoraro 2014-06-19 12:59:51 PDT
This appears to be a CodeMirror 4 regression, because CodeMirror now has a basic keymap for "Esc".
Comment 2 Radar WebKit Bug Importer 2014-06-19 13:01:04 PDT
<rdar://problem/17382967>
Comment 3 Joseph Pecoraro 2014-06-19 13:02:09 PDT
In CodeMirror 4 with multiple selection:

    Esc - singleSelection
    When multiple selections are present, this deselects all but the primary selection.
Comment 4 Joseph Pecoraro 2014-06-19 13:09:01 PDT
Maybe, CodeMirror should only prevent default if it actually did something.

In any case we may be able to workaround this because we only want to toggle the console when there is no text.
Comment 5 Joseph Pecoraro 2014-06-19 14:27:32 PDT
This was annoying me quite a bit, so I made a workaround. I think we should still go through and suggest a code mirror change to only prevent default if an action was taken (if multiple selections were collapsed to one).
Comment 6 Joseph Pecoraro 2014-06-19 14:27:48 PDT
Created attachment 233383 [details]
[PATCH] Proposed Fix
Comment 7 Timothy Hatcher 2014-06-19 14:30:23 PDT
Comment on attachment 233383 [details]
[PATCH] Proposed Fix

Looks good! I agree that CodeMirror should pass on the key if it doesn't do anything.
Comment 8 WebKit Commit Bot 2014-06-21 07:51:43 PDT
Comment on attachment 233383 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 233383

Committed r170238: <http://trac.webkit.org/changeset/170238>
Comment 9 WebKit Commit Bot 2014-06-21 07:51:46 PDT
All reviewed patches have been landed.  Closing bug.