Bug 134004

Summary: [iOS][wk2] Ensure that layers are marked volatile before allowing the process to suspend
Product: WebKit Reporter: Tim Horton <thorton>
Component: WebKit2Assignee: Tim Horton <thorton>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, barraclough, benjamin, commit-queue, simon.fraser
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 134189    
Bug Blocks:    
Attachments:
Description Flags
patch
simon.fraser: review+
with simon's changes none

Description Tim Horton 2014-06-17 16:45:51 PDT
WebKit tries to make layers volatile when unparented, but sometimes isn't given a chance to do so before the process gets suspended, so we end up with lots of non-volatile surfaces that should really be volatile.

<rdar://problem/17186342>
Comment 1 Tim Horton 2014-06-17 17:13:20 PDT
Created attachment 233271 [details]
patch
Comment 2 Simon Fraser (smfr) 2014-06-17 18:26:11 PDT
Comment on attachment 233271 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=233271&action=review

> Source/WebKit2/Shared/mac/RemoteLayerBackingStoreCollection.h:65
> +    bool markBackingStoreVolatileImmediately(RemoteLayerBackingStore&, unsigned volatilityMarkingFlags = 0);

enum for the set of flag mask please, not unsigned.

> Source/WebKit2/Shared/mac/RemoteLayerBackingStoreCollection.mm:160
> +    for (const auto& backingStore : m_unparentedBackingStore)

Blank line above please.

> Source/WebKit2/UIProcess/ios/ProcessThrottler.mm:109
> +    // If the process is currently waiting for the WebProcess to become suspendable but would become runnable,
> +    // let it know that it can cancel the suspension cleanup.

Hard to grok
Comment 3 Tim Horton 2014-06-17 18:44:37 PDT
(In reply to comment #2)
> (From update of attachment 233271 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=233271&action=review
> 
> > Source/WebKit2/Shared/mac/RemoteLayerBackingStoreCollection.h:65
> > +    bool markBackingStoreVolatileImmediately(RemoteLayerBackingStore&, unsigned volatilityMarkingFlags = 0);
> 
> enum for the set of flag mask please, not unsigned.

To clarify, .smfr says to use a typedef of unsigned for the flag argument type.
Comment 4 Tim Horton 2014-06-17 19:23:49 PDT
Created attachment 233277 [details]
with simon's changes

This patch will now sit here for a bit while I work on the final remaining piece in another bug.
Comment 5 WebKit Commit Bot 2014-06-17 19:25:52 PDT
Attachment 233277 [details] did not pass style-queue:


ERROR: Source/WebKit2/Shared/mac/RemoteLayerBackingStoreCollection.h:66:  The parameter name "volatilityMarkingFlags" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 15 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Gavin Barraclough 2014-06-17 22:27:42 PDT
LGTM
Comment 7 Tim Horton 2014-06-23 14:12:45 PDT
http://trac.webkit.org/changeset/170316