Bug 133759

Summary: Add LLVM FastISel abort option for coverage testing
Product: WebKit Reporter: Juergen Ributzka <juergen>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED WONTFIX    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Juergen Ributzka
Reported 2014-06-11 13:14:03 PDT
Add LLVM FastISel abort option for coverage testing
Attachments
Patch (4.14 KB, patch)
2014-06-11 13:21 PDT, Juergen Ributzka
no flags
Patch (4.08 KB, patch)
2014-06-12 16:44 PDT, Juergen Ributzka
no flags
Patch (4.12 KB, patch)
2014-06-18 10:04 PDT, Juergen Ributzka
no flags
Juergen Ributzka
Comment 1 2014-06-11 13:21:37 PDT
Filip Pizlo
Comment 2 2014-06-12 16:36:48 PDT
Comment on attachment 232894 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=232894&action=review > Source/JavaScriptCore/llvm/InitializeLLVMPOSIX.cpp:38 > +typedef LLVMAPI* (*InitializerFunction)(void (*)(const char*, ...), bool FastISelAbort); Call it fastISelAbort > Source/JavaScriptCore/llvm/library/LLVMExports.cpp:63 > +extern "C" JSC::LLVMAPI* initializeAndGetJSCLLVMAPI(void (*callback)(const char*, ...), bool FastISelAbort) Our naming convention would have this variable start with lower case: fastISelAbort.
Juergen Ributzka
Comment 3 2014-06-12 16:44:06 PDT
Geoffrey Garen
Comment 4 2014-06-16 11:44:42 PDT
Comment on attachment 233007 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=233007&action=review > Source/JavaScriptCore/llvm/library/LLVMExports.cpp:99 > + unsigned numArgs = sizeof(args) / sizeof(const char *) - (fastISelAbort ? 0 : 2); "char *" => "char*" in WebKit style.
Juergen Ributzka
Comment 5 2014-06-18 10:04:26 PDT
Juergen Ributzka
Comment 6 2014-06-18 10:06:05 PDT
Thanks Filip and Geoff. I am still not fully accustomed to the webkit coding style.
Juergen Ributzka
Comment 7 2014-11-11 13:02:47 PST
Abandon patch - it is obsolete.
Note You need to log in before you can comment on or make changes to this bug.