Bug 133014

Summary: [ftlopt] A StructureSet with one element should only require one word and no allocation
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, bunhere, commit-queue, ggaren, gyuyoung.kim, mark.lam, mhahnenberg, msaboff, oliver, rakuco, sam, sergio
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 128073    
Attachments:
Description Flags
it begins
none
it compiles
none
the patch oliver: review+

Filip Pizlo
Reported 2014-05-16 15:54:47 PDT
Patch forthcoming.
Attachments
it begins (11.56 KB, patch)
2014-05-16 15:55 PDT, Filip Pizlo
no flags
it compiles (29.39 KB, patch)
2014-05-16 20:39 PDT, Filip Pizlo
no flags
the patch (33.53 KB, patch)
2014-05-16 22:00 PDT, Filip Pizlo
oliver: review+
Filip Pizlo
Comment 1 2014-05-16 15:55:22 PDT
Created attachment 231600 [details] it begins
Oliver Hunt
Comment 2 2014-05-16 16:19:48 PDT
Comment on attachment 231600 [details] it begins View in context: https://bugs.webkit.org/attachment.cgi?id=231600&action=review > Source/JavaScriptCore/bytecode/StructureSet.h:423 > + void set(uintptr_t pointer, bool singleStructure) Where do we need this version? can we call it something else?
Filip Pizlo
Comment 3 2014-05-16 19:57:26 PDT
(In reply to comment #2) > (From update of attachment 231600 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=231600&action=review > > > Source/JavaScriptCore/bytecode/StructureSet.h:423 > > + void set(uintptr_t pointer, bool singleStructure) > > Where do we need this version? can we call it something else? It's used by the other set() methods.
Filip Pizlo
Comment 4 2014-05-16 20:39:05 PDT
Created attachment 231618 [details] it compiles
Filip Pizlo
Comment 5 2014-05-16 22:00:54 PDT
Created attachment 231622 [details] the patch
WebKit Commit Bot
Comment 6 2014-05-16 22:02:33 PDT
Attachment 231622 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:73: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:74: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:75: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:123: The parameter name "context" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:134: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:135: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:141: The parameter name "list" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 7 in 11 files If any of these errors are false positives, please file a bug against check-webkit-style.
Filip Pizlo
Comment 7 2014-05-16 22:39:05 PDT
(In reply to comment #6) > Attachment 231622 [details] did not pass style-queue: > > > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:73: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:74: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:75: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:123: The parameter name "context" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:134: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:135: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:141: The parameter name "list" adds no information, so it should be removed. [readability/parameter_name] [5] > Total errors found: 7 in 11 files Fixed! > > > If any of these errors are false positives, please file a bug against check-webkit-style.
Filip Pizlo
Comment 8 2014-05-20 22:17:46 PDT
Note You need to log in before you can comment on or make changes to this bug.