Bug 132050

Summary: [CSS Regions] Rename objectShouldPaintInFlowRegion to something more clear
Product: WebKit Reporter: Radu Stavila <stavila>
Component: CSSAssignee: Radu Stavila <stavila>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, esprehn+autocc, glenn, kondapallykalyan, simon.fraser, WebkitBugTracker
Priority: P2 Keywords: AdobeTracked
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 57312    
Attachments:
Description Flags
Patch none

Description Radu Stavila 2014-04-23 01:45:34 PDT
Rename objectShouldPaintInFlowRegion to something more clear as its no longer used just for painting, but also for hit-testing and other tasks.
Comment 1 Radu Stavila 2014-04-25 08:22:58 PDT
Created attachment 230180 [details]
Patch
Comment 2 Andreas Kling 2014-04-25 09:04:31 PDT
Comment on attachment 230180 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=230180&action=review

r=me

> Source/WebCore/rendering/RenderFlowThread.cpp:810
> +bool RenderFlowThread::objectShouldFragmentInFlowRegion(const RenderObject* object, const RenderRegion* region) const
>  {
>      ASSERT(object);
>      ASSERT(region);

The two ASSERTs here indicate that the arguments should really be references instead of pointers.
That kind of change does not belong in this patch though.
Comment 3 WebKit Commit Bot 2014-04-25 10:58:48 PDT
Comment on attachment 230180 [details]
Patch

Clearing flags on attachment: 230180

Committed r167810: <http://trac.webkit.org/changeset/167810>
Comment 4 WebKit Commit Bot 2014-04-25 10:58:51 PDT
All reviewed patches have been landed.  Closing bug.