Bug 131983

Summary: [GTK] Crash after getting web view context property with g_object_get
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: WebKit2Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: berto, commit-queue, gns, mrobinson, pnormand
Priority: P2 Keywords: Gtk
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch pnormand: review+

Description Carlos Garcia Campos 2014-04-22 05:07:17 PDT
The problem is that the getter is using g_value_take_object() and the default context is destroyed when the caller releases its ref. We should use g_value_set_object instead.
Comment 1 Carlos Garcia Campos 2014-04-22 05:09:12 PDT
Created attachment 229875 [details]
Patch
Comment 2 WebKit Commit Bot 2014-04-22 05:10:51 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Carlos Garcia Campos 2014-04-22 06:36:55 PDT
Committed r167656: <http://trac.webkit.org/changeset/167656>