Bug 131879

Summary: bmalloc: Mutex should be harder to use wrong
Product: WebKit Reporter: Geoffrey Garen <ggaren>
Component: New BugsAssignee: Geoffrey Garen <ggaren>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch kling: review+

Description Geoffrey Garen 2014-04-18 21:05:12 PDT
bmalloc: Mutex should be harder to use wrong
Comment 1 Geoffrey Garen 2014-04-18 21:09:42 PDT
Created attachment 229713 [details]
Patch
Comment 2 WebKit Commit Bot 2014-04-18 21:11:31 PDT
Attachment 229713 [details] did not pass style-queue:


ERROR: Source/bmalloc/bmalloc/StaticMutex.h:40:  try_lock is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/bmalloc/bmalloc/StaticMutex.h:60:  StaticMutex::try_lock is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/bmalloc/bmalloc/StaticMutex.cpp:26:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Total errors found: 3 in 15 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Andreas Kling 2014-04-19 00:33:21 PDT
Comment on attachment 229713 [details]
Patch

r=me
Comment 4 Geoffrey Garen 2014-04-19 11:37:21 PDT
Committed r167540: <http://trac.webkit.org/changeset/167540>