Bug 131160

Summary: [EFL][WK2] Add ewk API to allow accepting a specific TLS certificate for a specific host
Product: WebKit Reporter: Peter Molnar <pmolnar.u-szeged>
Component: WebKit EFLAssignee: Peter Molnar <pmolnar.u-szeged>
Status: RESOLVED FIXED    
Severity: Normal CC: bunhere, cdumez, commit-queue, gyuyoung.kim, gyuyoung.kim, hs85.jeong, lucas.de.marchi, man.zhong, ossy, ryuan.choi, sergio
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch
gyuyoung.kim: review+
patch for landing none

Description Peter Molnar 2014-04-03 05:46:43 PDT
Add ewk API to allow accepting a specific TLS certificate for a specific host
Comment 1 Peter Molnar 2014-04-03 05:49:44 PDT
Created attachment 228501 [details]
patch

The certificate is now passed though the EFL API as a PEM string, to avoid making it depend on libsoup (GTlsCertificate).

I don't know if there is a better way to do this, if you have any idea, please let me know.
Comment 2 Csaba Osztrogon√°c 2014-12-03 04:57:59 PST
Gyuyoung, what do you think about it?
Comment 3 Gyuyoung Kim 2014-12-03 18:38:35 PST
Comment on attachment 228501 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=228501&action=review

I don't have a big opinion about certification now. Patch looks fine to me.

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:442
> +EAPI void ewk_context_tls_certificate_for_host_allow(Ewk_Context *ewkContext, const char *pem, const char *host);

%s/ewkContext/context/g
Comment 4 Csaba Osztrogon√°c 2014-12-04 00:27:05 PST
Created attachment 242555 [details]
patch for landing
Comment 5 WebKit Commit Bot 2014-12-04 01:23:01 PST
Comment on attachment 242555 [details]
patch for landing

Clearing flags on attachment: 242555

Committed r176786: <http://trac.webkit.org/changeset/176786>
Comment 6 Hunseop Jeong 2014-12-04 05:44:16 PST
*** Bug 139254 has been marked as a duplicate of this bug. ***