Bug 130773

Summary: Rename hasFastArrayStorage to be more appropriate
Product: WebKit Reporter: Dániel Bátyai <dbatyai.u-szeged>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Severity: Normal CC: commit-queue, fpizlo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Proposed patch none

Description Dániel Bátyai 2014-03-26 05:36:55 PDT
In JavaScriptCore/runtime/IndexingType.h:
FIXME: This is an awkward name. This should really be called hasArrayStorage() and then next method down should be called hasAnyArrayStorage().
Comment 1 Dániel Bátyai 2014-03-26 05:41:22 PDT
Created attachment 227845 [details]
Proposed patch
Comment 2 WebKit Commit Bot 2014-03-26 08:08:39 PDT
Comment on attachment 227845 [details]
Proposed patch

Clearing flags on attachment: 227845

Committed r166292: <http://trac.webkit.org/changeset/166292>
Comment 3 WebKit Commit Bot 2014-03-26 08:08:41 PDT
All reviewed patches have been landed.  Closing bug.