Bug 129061

Summary: Move to using std::unique_ptr for KeyboardEvent, ScriptExecutionContext::PendingException
Product: WebKit Reporter: Zan Dobersek <zan>
Component: New BugsAssignee: Zan Dobersek <zan>
Status: RESOLVED FIXED    
Severity: Normal CC: calvaris, commit-queue, eric.carlson, esprehn+autocc, gyuyoung.kim, kangil.han, mkwst, ossy, philipj
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 129102    
Bug Blocks: 128007    
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description Zan Dobersek 2014-02-19 14:06:51 PST
Move to using std::unique_ptr for KeyboardEvent, ScriptExecutionContext::PendingException
Comment 1 Zan Dobersek 2014-02-19 14:17:45 PST
Created attachment 224675 [details]
Patch
Comment 2 Zan Dobersek 2014-02-20 01:51:44 PST
Comment on attachment 224675 [details]
Patch

Clearing flags on attachment: 224675

Committed r164422: <http://trac.webkit.org/changeset/164422>
Comment 3 Zan Dobersek 2014-02-20 01:51:51 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 Csaba Osztrogon√°c 2014-02-20 03:49:37 PST
(In reply to comment #2)
> (From update of attachment 224675 [details])
> Clearing flags on attachment: 224675
> 
> Committed r164422: <http://trac.webkit.org/changeset/164422>

It caused regressions on Apple Mac debug bots:
http://build.webkit.org/builders/Apple%20Mavericks%20Debug%20WK1%20%28Tests%29/builds/3145
Comment 5 WebKit Commit Bot 2014-02-20 05:45:14 PST
Re-opened since this is blocked by bug 129102
Comment 6 Zan Dobersek 2014-03-04 01:28:08 PST
Created attachment 225755 [details]
Patch
Comment 7 Eric Carlson 2014-03-04 09:09:41 PST
Comment on attachment 225755 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=225755&action=review

> Source/WebCore/html/track/LoadableTextTrack.cpp:107
>  void LoadableTextTrack::newCuesAvailable(TextTrackLoader* loader)
>  {
> -    ASSERT_UNUSED(loader, m_loader == loader);
> +    ASSERT_UNUSED(loader, m_loader.get() == loader);
>  
>      Vector<RefPtr<TextTrackCue>> newCues;
>      m_loader->getNewCues(newCues);

Isn't this part of your text track patch?
Comment 8 Zan Dobersek 2014-03-04 10:00:13 PST
Comment on attachment 225755 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=225755&action=review

>> Source/WebCore/html/track/LoadableTextTrack.cpp:107
>>      m_loader->getNewCues(newCues);
> 
> Isn't this part of your text track patch?

It should be. This got included by accident.
Comment 9 Zan Dobersek 2014-03-04 10:03:30 PST
Created attachment 225787 [details]
Patch
Comment 10 Zan Dobersek 2014-03-06 00:56:49 PST
Comment on attachment 225787 [details]
Patch

Clearing flags on attachment: 225787

Committed r165177: <http://trac.webkit.org/changeset/165177>
Comment 11 Zan Dobersek 2014-03-06 00:56:57 PST
All reviewed patches have been landed.  Closing bug.