Summary: | Fail FTL compilation if the required stack is too big | ||||||
---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | Michael Saboff <msaboff> | ||||
Component: | JavaScriptCore | Assignee: | Michael Saboff <msaboff> | ||||
Status: | RESOLVED FIXED | ||||||
Severity: | Normal | ||||||
Priority: | P2 | ||||||
Version: | 528+ (Nightly build) | ||||||
Hardware: | All | ||||||
OS: | All | ||||||
Bug Depends on: | |||||||
Bug Blocks: | 125650 | ||||||
Attachments: |
|
Description
Michael Saboff
2014-02-10 16:20:17 PST
Created attachment 223765 [details]
Patch
Comment on attachment 223765 [details]
Patch
r=me
Comment on attachment 223765 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=223765&action=review > Source/JavaScriptCore/ftl/FTLStackMaps.h:104 > + unsigned getStackSize() const; I would call this stackSize() and not getStackSize(). We don't usually prepend getters with "get". The reason why "getRecordMap()" has a "get" in it is that it actually has to do significant work to return the record map. Probably, that should be called "computeRecordMap()". But your "getStackSize" is not computing anything, and it's a getter, so lets just call it "stackSize()". Comment on attachment 223765 [details]
Patch
r=me but change the name of getStackSize
(In reply to comment #3) > (From update of attachment 223765 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=223765&action=review > > > Source/JavaScriptCore/ftl/FTLStackMaps.h:104 > > + unsigned getStackSize() const; > > I would call this stackSize() and not getStackSize(). We don't usually prepend getters with "get". The reason why "getRecordMap()" has a "get" in it is that it actually has to do significant work to return the record map. Probably, that should be called "computeRecordMap()". But your "getStackSize" is not computing anything, and it's a getter, so lets just call it "stackSize()". Agreed. I'll change it. Committed r163838: <http://trac.webkit.org/changeset/163838> |