Bug 128369

Summary: [GTK] Re-enable gtk-doc in EWS
Product: WebKit Reporter: Manuel Rego Casasnovas <rego>
Component: WebKitGTKAssignee: Manuel Rego Casasnovas <rego>
Status: RESOLVED FIXED    
Severity: Normal CC: aperez, cgarcia, commit-queue, glenn, gustavo, mrobinson, zan
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 129302    
Bug Blocks:    
Attachments:
Description Flags
Patch none

Description Manuel Rego Casasnovas 2014-02-07 02:49:21 PST
gtk-doc is currently scanning the source dir to generate the document, so if you're doing a clean build and you have added some files gtk-doc is going to fail.
Comment 1 Carlos Garcia Campos 2014-02-07 03:02:03 PST
The problem is not the source dir in the particular case of EWS, but the buildir. What happens is the following:

1.- A patch adding new GObject DOM bindings API is submitted to bugzilla. It's built generating new classes in the derived sources
2.- Another patch is submitted to bugzilla reusing the existing builddir. The new classes generated by the previous patch are still there, but they are not built by this new patch. However, generate-gtkdoc scans the buildir to generate the doc, and it fails when trying to generate the doc of the new classes added by a previous patch and not built.

I have had the same problem locally when I'm working on new classes in a branch, switch to another branch leaving the new classes in my source tree, but not building them, and gtkdoc fails when trying to generate docs for those new clases. Again, because it scans the source tree.

So yes, the problem is that generate-gtkdoc scans the source tree/derived sources dir, instead of receiving the input files from the makefile like all other tools do (gobject-run-api-break-test, gobject-introspection, etc.).

The *only* problem of doing it the right way is that it's more unconvenient to generate the docs manually (currently we only need to call generate-gtkdoc script with no arguments), but we can use a different script to scan the input files, or make the script smart enough to not scan dirs when input is provided. By providing the input files we also avoid all the ugly filters we have to not generate docs for private api/files.
Comment 2 Manuel Rego Casasnovas 2014-02-07 03:42:19 PST
gtk-doc generation has been disabled in the EWS in r163621 (see bug #128370).
Comment 3 Manuel Rego Casasnovas 2014-02-25 01:18:06 PST
This was already fixed in bug #128417, so gtk-doc can be enabled again in the EWS and the FIXMEs can be removed.
Comment 4 Manuel Rego Casasnovas 2014-02-25 01:19:52 PST
Created attachment 225129 [details]
Patch
Comment 5 WebKit Commit Bot 2014-02-25 02:00:12 PST
Comment on attachment 225129 [details]
Patch

Clearing flags on attachment: 225129

Committed r164639: <http://trac.webkit.org/changeset/164639>
Comment 6 WebKit Commit Bot 2014-02-25 02:00:14 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 WebKit Commit Bot 2014-02-25 05:59:20 PST
Re-opened since this is blocked by bug 129302
Comment 8 Manuel Rego Casasnovas 2014-02-26 03:27:25 PST
Committed r164713: <http://trac.webkit.org/changeset/164713>