Bug 128333

Summary: Web Inspector: show probe sets for script content views in the details sidebar
Product: WebKit Reporter: BJ Burg <bburg>
Component: Web InspectorAssignee: BJ Burg <bburg>
Status: RESOLVED FIXED    
Severity: Normal CC: graouts, joepeck, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on: 128332    
Bug Blocks:    
Attachments:
Description Flags
patch - maybe needs new asset instead of PDF glyph timothy: review+

Description BJ Burg 2014-02-06 14:31:32 PST
Upstreaming this will include:

ProbeDetailsSidebarPanel
ProbeSetDetailsSection
ProbeSetDataGrid
EventListenerSet

and some glue code to make the sidebar show up at the right times.
Comment 1 Radar WebKit Bug Importer 2014-02-06 14:32:06 PST
<rdar://problem/16005982>
Comment 2 BJ Burg 2014-02-07 21:06:57 PST
Created attachment 223545 [details]
patch - maybe needs new asset instead of PDF glyph
Comment 3 Timothy Hatcher 2014-02-08 10:14:07 PST
Comment on attachment 223545 [details]
patch - maybe needs new asset instead of PDF glyph

View in context: https://bugs.webkit.org/attachment.cgi?id=223545&action=review

> Source/WebInspectorUI/UserInterface/DataGrid.js:385
> +    insertColumn: function(columnIdentifier, columnData, insertionIndex) {

Some newlines in this function would help readability.

> Source/WebInspectorUI/UserInterface/DataGrid.js:399
> +        console.log("columns ", this.orderedColumns.slice());

Debug statement.

> Source/WebInspectorUI/UserInterface/ProbeSetDataGridNode.js:101
> +            default: console.log("Don't know how to represent sample:", sample);

console.error?
Comment 4 BJ Burg 2014-02-08 16:31:32 PST
(In reply to comment #3)
> (From update of attachment 223545 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=223545&action=review
> 
> > Source/WebInspectorUI/UserInterface/DataGrid.js:385
> > +    insertColumn: function(columnIdentifier, columnData, insertionIndex) {
> 
> Some newlines in this function would help readability.

I added a few, but the code is already put into 5-line chunks for setting up each DOM element or whatever. Not sure how much more can be split into separate actions.
Comment 5 BJ Burg 2014-02-08 18:51:53 PST
Committed r163735: <http://trac.webkit.org/changeset/163735>