Bug 128130

Summary: NavigationState should be a PageLoadState::Observer
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch darin: review+

Description Anders Carlsson 2014-02-03 14:59:36 PST
NavigationState should be a PageLoadState::Observer
Comment 1 Anders Carlsson 2014-02-03 15:03:21 PST
Created attachment 223027 [details]
Patch
Comment 2 Darin Adler 2014-02-03 15:22:26 PST
Comment on attachment 223027 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=223027&action=review

> Source/WebKit2/UIProcess/API/Cocoa/WKWebViewInternal.h:38
> +#if PLATFORM(IOS)
> +#import "WKContentViewInternal.h"
> +#import <UIKit/UIScrollView_Private.h>
> +#import <UIKit/_UIWebViewportHandler.h>
> +
> +#define WK_WEB_VIEW_PROTOCOLS <UIScrollViewDelegate, WKContentViewDelegate, _UIWebViewportHandlerDelegate>
> +#endif

The paragraphing here is hard to read. I’d almost prefer two separate if statements.

> Source/WebKit2/UIProcess/API/Cocoa/WKWebViewInternal.h:42
> +#if PLATFORM(MAC) && !PLATFORM(IOS)
> +#define WK_WEB_VIEW_PROTOCOLS
> +#endif

Maybe just:

#if !defined(WK_WEB_VIEW_PROTOCOLS)
#define WK_WEB_VIEW_PROTOCOLS
#endif

> Source/WebKit2/UIProcess/Cocoa/NavigationState.h:92
> +    // PageLoadState::Observer
> +    virtual void willChangeIsLoading() override;
> +    virtual void didChangeIsLoading() override;

Without a blank line, this comment seems to be grouped with only these first two overrides, so I suggest different formatting.

> Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:340
> +    printf("%s!\n", __PRETTY_FUNCTION__);

Do we really want to land this?

> Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:345
> +    printf("%s!\n", __PRETTY_FUNCTION__);

Do we really want to land this?
Comment 3 Anders Carlsson 2014-02-03 15:28:35 PST
Committed r163332: <http://trac.webkit.org/changeset/163332>
Comment 4 mitz 2014-02-03 15:36:20 PST
Comment on attachment 223027 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=223027&action=review

> Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:34
> +#import "PageLoadState.h"

P < W

> Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:340
> +    printf("%s!\n", __PRETTY_FUNCTION__);

No!

> Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:345
> +    printf("%s!\n", __PRETTY_FUNCTION__);

No!