Bug 127912

Summary: IDB: Add no-op plumbing for deleteDatabase and deleteRange
Product: WebKit Reporter: Brady Eidson <beidson>
Component: WebKit2Assignee: Brady Eidson <beidson>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 124521    
Attachments:
Description Flags
Patch v1 ap: review+

Description Brady Eidson 2014-01-30 09:31:39 PST
IDB: Add no-op plumbing for deleteDatabase and deleteRange

To get rid of future busywork...
Comment 1 Brady Eidson 2014-01-30 09:34:18 PST
Created attachment 222676 [details]
Patch v1
Comment 2 WebKit Commit Bot 2014-01-30 09:35:56 PST
Attachment 222676 [details] did not pass style-queue:


ERROR: Source/WebKit2/DatabaseProcess/IndexedDB/DatabaseProcessIDBConnection.h:91:  The parameter name "keyRange" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebKit2/DatabaseProcess/IndexedDB/UniqueIDBDatabase.cpp:650:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Total errors found: 2 in 9 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Alexey Proskuryakov 2014-01-30 09:42:21 PST
Comment on attachment 222676 [details]
Patch v1

View in context: https://bugs.webkit.org/attachment.cgi?id=222676&action=review

> Source/WebKit2/DatabaseProcess/IndexedDB/UniqueIDBDatabase.cpp:639
> +void UniqueIDBDatabase::deleteRange(const IDBIdentifier& transactionIdentifier, int64_t objectStoreID, const WebCore::IDBKeyRangeData& keyRangeData, std::function<void(uint32_t, const String&)> callback)

Please check all cpp files for WebCore namespace prefixes, and remove them.
Comment 4 Brady Eidson 2014-01-30 09:44:42 PST
(In reply to comment #3)
> (From update of attachment 222676 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=222676&action=review
> 
> > Source/WebKit2/DatabaseProcess/IndexedDB/UniqueIDBDatabase.cpp:639
> > +void UniqueIDBDatabase::deleteRange(const IDBIdentifier& transactionIdentifier, int64_t objectStoreID, const WebCore::IDBKeyRangeData& keyRangeData, std::function<void(uint32_t, const String&)> callback)
> 
> Please check all cpp files for WebCore namespace prefixes, and remove them.

Whoops, thanks!
Comment 5 Brady Eidson 2014-01-30 09:45:31 PST
http://trac.webkit.org/changeset/163087