Bug 127900

Summary: Web Inspector: Show profile data in the discrete Scripts timeline view
Product: WebKit Reporter: Timothy Hatcher <timothy>
Component: Web InspectorAssignee: Timothy Hatcher <timothy>
Status: RESOLVED FIXED    
Severity: Normal CC: graouts, joepeck, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch
joepeck: review+, timothy: commit-queue-
Screenshot none

Description Timothy Hatcher 2014-01-30 02:35:21 PST
Start showing profile data in the DataGrid of the ScriptTimelineView.
Comment 1 Radar WebKit Bug Importer 2014-01-30 02:35:51 PST
<rdar://problem/15944978>
Comment 2 Timothy Hatcher 2014-01-30 02:43:16 PST
Created attachment 222653 [details]
Patch
Comment 3 Timothy Hatcher 2014-01-30 02:46:44 PST
Created attachment 222654 [details]
Screenshot
Comment 4 Joseph Pecoraro 2014-01-30 11:44:20 PST
Comment on attachment 222653 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=222653&action=review

r=me

> Source/WebInspectorUI/ChangeLog:3
> +        Show profile data in the desecrate Scripts timeline view.

Typo: "desecrate"

> Source/WebInspectorUI/UserInterface/NavigationSidebarPanel.js:543
> +            // Keep all the elements at the same depth once the maximum is reached.
> +            childrenSubstring += i === maximumSidebarTreeDepth ? " .children" : " > .children";
> +            styleText += "." + WebInspector.NavigationSidebarPanel.ContentTreeOutlineElementStyleClassName + childrenSubstring + " > .item { ";

This must be some kind of a record for longest selector.

> Source/WebInspectorUI/UserInterface/ProfileNodeDataGridNode.js:35
> +    this._rangeEndTime = rangeEndTime || Infinity;

"0 || 0" is harmless, but  "0 || Infinity" could lead to a crazy accident. Maybe we should be a bit safer here?

> Source/WebInspectorUI/UserInterface/ScriptTimelineDataGridNode.js:33
> +    this._rangeEndTime = rangeEndTime || Infinity;

Ditto, 0 || Infinity.

> Source/WebInspectorUI/UserInterface/ScriptTimelineView.js:119
> +                dataGridNode = dataGridNode.traverseNextNode(false, null, true);

Gosh, these traverse functions need a better name to read at call sites. Same with that reveal function with a bunch of bools.

> Source/WebInspectorUI/UserInterface/TimelineDataGrid.js:274
> +        // Collect parent nodes htat need their children sorted. So this in two phases since

Typo: "htat"
Comment 5 Timothy Hatcher 2014-01-30 17:32:01 PST
https://trac.webkit.org/r163142