Bug 127258

Summary: Web Inspector: Generate better display names for timer and event Timeline records
Product: WebKit Reporter: Timothy Hatcher <timothy>
Component: Web InspectorAssignee: Timothy Hatcher <timothy>
Status: RESOLVED FIXED    
Severity: Normal CC: graouts, joepeck, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch joepeck: review+, timothy: commit-queue-

Description Timothy Hatcher 2014-01-19 14:48:53 PST
The event record should say what event it was. And the timer record should optionally say what the timer identifier was.
Comment 1 Radar WebKit Bug Importer 2014-01-19 14:49:02 PST
<rdar://problem/15855340>
Comment 2 Timothy Hatcher 2014-01-19 14:56:41 PST
Created attachment 221597 [details]
Patch
Comment 3 Joseph Pecoraro 2014-01-20 13:09:27 PST
Comment on attachment 221597 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=221597&action=review

r=me

> Source/WebInspectorUI/UserInterface/ScriptTimelineRecord.js:61
> +    if (details && !WebInspector.ScriptTimelineRecord._eventDisplayNames) {
> +        // These display names are not localized because they closely represent
> +        // the real API name, just with word spaces and Title Case.
> +
> +        var nameMap = new Map;
> +        nameMap.set("DOMActivate", "DOM Activate");
> +        nameMap.set("DOMCharacterDataModified", "DOM Character Data Modified");
> +        nameMap.set("DOMContentLoaded", "DOM Content Loaded");
> +        nameMap.set("DOMFocusIn", "DOM Focus In");
> +        nameMap.set("DOMFocusOut", "DOM Focus Out");

I wonder if a static object literal would be faster, or if this is negligible.

I think I'm actually in favor of seeing the actual event name. For example if I want to filter for a "beforecopy" event, I'll type that; not "Before Copy". So I could end up errantly not finding a record?

> Source/WebInspectorUI/UserInterface/ScriptTimelineRecord.js:178
> +        nameMap.set("webkitcurrentplaybacktargetiswirelesschanged", "Current Playback Target Is Wireless Changed");

My claim to fame.

> Source/WebInspectorUI/UserInterface/ScriptTimelineView.js:-46
> -    columns.details.title = WebInspector.UIString("Details");
> -    columns.details.width = "15%";
> -

Should we prefer this 15% be spread out to the others in some way? Give more to location?
Comment 4 Timothy Hatcher 2014-01-20 19:05:33 PST
https://trac.webkit.org/changeset/162420