Bug 126696

Summary: DocumentOrderedMap should use iterator
Product: WebKit Reporter: Antti Koivisto <koivisto>
Component: DOMAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, esprehn+autocc, kangil.han, kling, rniwa
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch
none
better patch kling: review+

Description Antti Koivisto 2014-01-09 07:38:38 PST
Instead of ElementTraversal
Comment 1 Antti Koivisto 2014-01-09 07:52:26 PST
Created attachment 220734 [details]
patch
Comment 2 Antti Koivisto 2014-01-09 08:15:08 PST
Created attachment 220738 [details]
better patch
Comment 3 Andreas Kling 2014-01-09 08:48:35 PST
Comment on attachment 220738 [details]
better patch

View in context: https://bugs.webkit.org/attachment.cgi?id=220738&action=review

> Source/WebCore/dom/DocumentOrderedMap.cpp:213
> +        auto elementDescandants = descendantsOfType<Element>(*scope.rootNode());

Typo, descandants.

> Source/WebCore/dom/DocumentOrderedMap.cpp:214
> +        auto it = entry.element ? elementDescandants.find(*entry.element) : elementDescandants.begin();

We need a better name for find(). beginAt()?
Comment 4 Antti Koivisto 2014-01-09 12:18:26 PST
https://trac.webkit.org/r161572