Bug 126363

Summary: Remove elementChildren/elementDescendants shorthands
Product: WebKit Reporter: Antti Koivisto <koivisto>
Component: DOMAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: darin
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch andersca: review+

Description Antti Koivisto 2014-01-01 13:25:50 PST
Just use childrenOfType<Element>/descendantsOfType<Element> instead.
Comment 1 Antti Koivisto 2014-01-01 13:30:42 PST
Created attachment 220192 [details]
patch
Comment 2 Antti Koivisto 2014-01-01 13:45:02 PST
https://trac.webkit.org/r161196
Comment 3 Darin Adler 2014-01-01 21:34:24 PST
Do childrenOfType and descendantsOfType really need “OfType” in their names?
Comment 4 Antti Koivisto 2014-01-02 00:37:57 PST
(In reply to comment #3)
> Do childrenOfType and descendantsOfType really need “OfType” in their names?

Probably not.
Comment 5 Antti Koivisto 2014-01-02 00:46:33 PST
(In reply to comment #4)
> (In reply to comment #3)
> > Do childrenOfType and descendantsOfType really need “OfType” in their names?
> 
> Probably not.

With such generic names collisions with local variables and class members might get annoying. But maybe it is not a real problem.