Bug 126290

Summary: [SOUP] willSendRequest doesn't work after a redirect
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, commit-queue, danw, gns, mrobinson, rakuco, svillar
Priority: P2 Keywords: Soup
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 126291    
Attachments:
Description Flags
Patch mrobinson: review+

Description Carlos Garcia Campos 2013-12-30 08:01:40 PST
The problem is that we are creating the new soup request for the redirect before calling ResourceHandleClient::willSendRequest() so that any change made to the request by the client is ignored.
Comment 1 Carlos Garcia Campos 2013-12-30 08:06:16 PST
Created attachment 220109 [details]
Patch
Comment 2 WebKit Commit Bot 2013-12-30 08:08:15 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Carlos Garcia Campos 2013-12-31 00:24:45 PST
Committed r161176: <http://trac.webkit.org/changeset/161176>