Bug 12531

Summary: REGRESSION: Inline text input seriously F'd in latest nightly (r19336)
Product: WebKit Reporter: Julian Grybowski <jgrybows>
Component: TextAssignee: Darin Adler <darin>
Status: RESOLVED FIXED    
Severity: Critical CC: adele, ap, dragonadvertising, hyeonseok, vincentqvu
Priority: P1 Keywords: InRadar, Regression
Version: 420+   
Hardware: Mac   
OS: OS X 10.4   
URL: http://www.google.com

Description Julian Grybowski 2007-02-01 09:40:36 PST
Steps to reproduce:

1. Navigate to a page with a text field or textarea.

2. Switch to Kotoeri (Japanese input).

3. Try typing something. Doesn't matter what.

Results:
The engine seems to read each keypress multiple times (like, dozens), resulting in long strings of sokuon and vowels, with little-to-no usefulness when it comes to typing something coherent. Unless you *intend* to type out a bunch of reeaaally loooooong geminated consonants and vowels.

This doesn't affect the Google search box in the toolbar; only content on pages. I've been told by ap that this is the result of recent to event dispatches... hopefully that helps isolate the cause of this problem.
Comment 1 Alexey Proskuryakov 2007-02-01 09:44:14 PST
Happens with other input methods, too.
Comment 2 Alexey Proskuryakov 2007-02-03 23:30:07 PST
*** Bug 12563 has been marked as a duplicate of this bug. ***
Comment 3 Alexey Proskuryakov 2007-02-03 23:34:21 PST
See also: bug 12539.
Comment 4 Maciej Stachowiak 2007-02-04 11:49:00 PST
<rdar://problem/4975126>
Comment 5 Alexey Proskuryakov 2007-02-08 22:30:33 PST
*** Bug 12684 has been marked as a duplicate of this bug. ***
Comment 6 Darin Adler 2007-02-11 12:16:51 PST
My patch attached to bug 10010 fixes this bug too. I'll fix the change log to mention that.
Comment 7 Carl 2007-02-11 17:16:35 PST
build # 19564 still not working
Comment 8 Julian Grybowski 2007-02-11 18:49:28 PST
(In reply to comment #7)
> build # 19564 still not working
> 

Yes, we know. The status of the bug hasn't changed. There's a patch that covers this bug and two others, but it isn't ready to be applied yet.

If it was months or years down the road with no change, or if it was supposed to be fixed but wasn't, it might be worthwhile to note that the problem still persists. But since this bug was filed less than two weeks ago, and has had people working on it more or less constantly, that really isn't necessary.
Comment 9 Darin Adler 2007-02-12 11:22:11 PST
Committed revision 19579.
Comment 10 David Kilzer (:ddkilzer) 2007-02-12 13:30:03 PST
*** Bug 12747 has been marked as a duplicate of this bug. ***