Bug 125206

Summary: [EFL][WK2] Fix build after API::Client changes
Product: WebKit Reporter: Nick Diego Yamane (diegoyam) <nick.diego>
Component: WebKit EFLAssignee: Nick Diego Yamane (diegoyam) <nick.diego>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, cdumez, cgarcia, cmarcelo, commit-queue, gustavo, gyuyoung.kim, gyuyoung.kim, lucas.de.marchi, luiz, mrobinson, noam, ossy, rakuco, zeno
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 125182    
Bug Blocks:    
Attachments:
Description Flags
Patch none

Description Nick Diego Yamane (diegoyam) 2013-12-03 18:53:21 PST
Bug 125129 changed the way WK2 API::ClientTraits are implemented, to use a template-based approach.
After that EFL WK2 build is broken. To fix that we should make modifications similar to what is being done in bug 125129 and bug 125182.
Comment 1 Nick Diego Yamane (diegoyam) 2013-12-03 20:37:34 PST
Created attachment 218379 [details]
Patch

EFL changes including the changes from bug 125182, which this bug depends on. Initially to see the buildbot results.
Comment 2 WebKit Commit Bot 2013-12-03 20:39:50 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Csaba Osztrogon√°c 2013-12-04 00:46:00 PST
Comment on attachment 218379 [details]
Patch

I'm not 100% sure if it is the proper change. But we don't know anything about
the original change and its author and WK2 owners are unreachable. :((

So r=me to fix the build as soon as possible. We can always revise
the patch later if we get feedback from WK2 owners.
Comment 4 Csaba Osztrogon√°c 2013-12-04 00:55:58 PST
landed in http://trac.webkit.org/changeset/160075
Comment 5 Gustavo Noronha (kov) 2013-12-04 02:56:27 PST
*** Bug 125182 has been marked as a duplicate of this bug. ***