Bug 125052

Summary: Instead of watchpointing activation allocation, we should watchpoint entry into functions that have captured variables
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, commit-queue, ggaren, mark.lam, mhahnenberg, msaboff, oliver, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 124630    
Attachments:
Description Flags
stuff
none
the patch mhahnenberg: review+

Description Filip Pizlo 2013-12-01 18:15:42 PST
Patch forthcoming.
Comment 1 Filip Pizlo 2013-12-01 18:23:45 PST
Created attachment 218129 [details]
stuff
Comment 2 Filip Pizlo 2013-12-01 18:53:09 PST
Created attachment 218131 [details]
the patch
Comment 3 WebKit Commit Bot 2013-12-01 18:54:57 PST
Attachment 218131 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source/JavaScriptCore/bytecode/BytecodeLivenessAnalysis.cpp', u'Source/JavaScriptCore/bytecode/CodeBlock.cpp', u'Source/JavaScriptCore/bytecode/Opcode.h', u'Source/JavaScriptCore/bytecode/Watchpoint.h', u'Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp', u'Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp', u'Source/JavaScriptCore/dfg/DFGCapabilities.cpp', u'Source/JavaScriptCore/dfg/DFGWatchpointCollectionPhase.cpp', u'Source/JavaScriptCore/jit/JIT.cpp', u'Source/JavaScriptCore/jit/JIT.h', u'Source/JavaScriptCore/jit/JITOpcodes.cpp', u'Source/JavaScriptCore/llint/LowLevelInterpreter.asm', u'Source/JavaScriptCore/runtime/CommonSlowPaths.cpp', u'Source/JavaScriptCore/runtime/CommonSlowPaths.h', u'Source/JavaScriptCore/runtime/JSActivation.h', u'Source/JavaScriptCore/runtime/SymbolTable.cpp', u'Source/JavaScriptCore/runtime/SymbolTable.h']" exit_code: 1
Source/JavaScriptCore/jit/JIT.cpp:165:  Non-label code inside switch statements should be indented.  [whitespace/indent] [4]
Total errors found: 1 in 18 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Mark Hahnenberg 2013-12-02 10:56:11 PST
Comment on attachment 218131 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=218131&action=review

r=me with comments.

> Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp:3012
>                      addToGraph(ActivationAllocationWatchpoint, OpInfo(activation->symbolTable()));

Maybe rename ActivationAllocationWatchpoint to FunctionReentryWatchpoint?

> Source/JavaScriptCore/dfg/DFGWatchpointCollectionPhase.cpp:129
>          case ActivationAllocationWatchpoint:

Ditto.
Comment 5 Filip Pizlo 2013-12-02 11:06:47 PST
Landed in http://trac.webkit.org/changeset/159942