Bug 124873

Summary: Don't parent the TileController root layer in two places
Product: WebKit Reporter: Tim Horton <thorton>
Component: Layout and RenderingAssignee: Tim Horton <thorton>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, commit-queue, sam, simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch none

Description Tim Horton 2013-11-25 17:18:26 PST
The TileController root layer gets parented both directly and as a "custom" sublayer of its owning layer.

We don't need to parent it directly, only the custom sublayer mechanism was intended to be used (so that they'll stay put in the layer hierarchy).
Comment 1 Tim Horton 2013-11-25 17:20:45 PST
Created attachment 217850 [details]
patch
Comment 2 Brent Fulgham 2013-11-26 19:19:45 PST
Comment on attachment 217850 [details]
patch

r=me. Parenting yourself is gross!  Gross I say!
Comment 3 WebKit Commit Bot 2013-11-26 19:47:35 PST
Comment on attachment 217850 [details]
patch

Clearing flags on attachment: 217850

Committed r159800: <http://trac.webkit.org/changeset/159800>
Comment 4 WebKit Commit Bot 2013-11-26 19:47:36 PST
All reviewed patches have been landed.  Closing bug.