Bug 124801

Summary: [Win] Port run-jsc-stress-tests
Product: WebKit Reporter: Brent Fulgham <bfulgham>
Component: Tools / TestsAssignee: Brent Fulgham <bfulgham>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, fpizlo, webkit-bug-importer
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 120809    
Attachments:
Description Flags
Patch fpizlo: review+

Description Brent Fulgham 2013-11-22 16:24:53 PST
Windows does not currently run the new JavaScriptCore stress tests.  We need to get these running so we can identify and fix regressions as soon as they are introduced.
Comment 1 Brent Fulgham 2013-12-02 13:19:20 PST
Created attachment 218209 [details]
Patch
Comment 2 Brent Fulgham 2013-12-02 14:10:55 PST
I landed the correction to run-jsc-stress-test, but did not turn the tests on for Windows (yet) because I found a large number of failing stress-test cases.

I'm opening a separate bug to resolve this issue before activating stress tests on Windows.
Comment 3 Brent Fulgham 2013-12-02 14:19:00 PST
Committed r159961: <http://trac.webkit.org/changeset/159961>
Comment 4 Brent Fulgham 2013-12-02 16:44:38 PST
See Bug 125111 for failing cases.