Bug 124344

Summary: [sh4] Build fails since r159276.
Product: WebKit Reporter: Julien Brianceau <jbriance>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, msaboff
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 124347    
Attachments:
Description Flags
Use r14 register instead of fp in sh4.rb none

Description Julien Brianceau 2013-11-14 04:45:11 PST
sh4 build is broken since http://trac.webkit.org/changeset/159276
Comment 1 Julien Brianceau 2013-11-14 04:49:29 PST
Created attachment 216920 [details]
Use r14 register instead of fp in sh4.rb

This just fixes the build. I'll submit another patch soon to fix crashes with sh4 arch (regression from r159276).
Comment 2 Csaba Osztrogon√°c 2013-11-14 04:54:46 PST
Comment on attachment 216920 [details]
Use r14 register instead of fp in sh4.rb

rs=me
Comment 3 WebKit Commit Bot 2013-11-14 05:25:54 PST
Comment on attachment 216920 [details]
Use r14 register instead of fp in sh4.rb

Clearing flags on attachment: 216920

Committed r159283: <http://trac.webkit.org/changeset/159283>
Comment 4 WebKit Commit Bot 2013-11-14 05:25:56 PST
All reviewed patches have been landed.  Closing bug.