Bug 123437

Summary: [GStreamer] Remove NATIVE_FULLSCREEN_VIDEO support
Product: WebKit Reporter: Philippe Normand <pnormand>
Component: PlatformAssignee: Xabier Rodríguez Calvar <calvaris>
Status: RESOLVED FIXED    
Severity: Normal CC: calvaris, cdumez, commit-queue, eric.carlson, glenn, gustavo, gyuyoung.kim, jer.noble, menard, mrobinson, rakuco
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 122831    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Patch none

Description Philippe Normand 2013-10-29 01:01:26 PDT
This code path has been disabled for months, better to remove it once for all.
Comment 1 Xabier Rodríguez Calvar 2013-10-29 02:46:52 PDT
(In reply to comment #0)
> This code path has been disabled for months, better to remove it once for all.

I think it is better to keep it because in the end we should use it, but the problem is that the native controls have problems and also need a redisign.
Comment 2 Philippe Normand 2013-10-29 02:53:37 PDT
Well, now that we have hw accelerated decoding/rendering I don't think this is needed anymore.
Comment 3 Xabier Rodríguez Calvar 2013-10-29 03:51:56 PDT
Yes, and we always have the possibiilty of bringing the code back from repository.
Comment 4 Xabier Rodríguez Calvar 2013-11-04 09:45:37 PST
Created attachment 215927 [details]
Patch

Removed all references to NATIVE_FULLSCREEN_VIDEO related to GStreamer code.
Comment 5 Philippe Normand 2013-11-04 09:55:03 PST
Comment on attachment 215927 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=215927&action=review

Nice clean-up!

> Source/WebCore/ChangeLog:8
> +        No new tests (OOPS!).

The commit hooks don't like OOPS!. Can you also please provide a short explanation and at least mention this is about removing dead code?
Comment 6 Philippe Normand 2013-11-04 09:59:11 PST
Forgot to mention the dependency on gstreamer-video-1.0 can perhaps be removed now, needs double checking though.
Comment 7 Xabier Rodríguez Calvar 2013-11-04 11:16:54 PST
(In reply to comment #6)
> Forgot to mention the dependency on gstreamer-video-1.0 can perhaps be removed now, needs double checking though.

Though I could remove the use of some headers, I cannot remove that dependency because it is still used.
Comment 8 Xabier Rodríguez Calvar 2013-11-04 11:26:17 PST
Created attachment 215935 [details]
Patch

Removed some header declarations and updated changelogs.
Comment 9 WebKit Commit Bot 2013-11-05 01:06:20 PST
Comment on attachment 215935 [details]
Patch

Clearing flags on attachment: 215935

Committed r158656: <http://trac.webkit.org/changeset/158656>
Comment 10 WebKit Commit Bot 2013-11-05 01:06:23 PST
All reviewed patches have been landed.  Closing bug.