Bug 122345

Summary: [iOS] Upstream support for -webkit-video-playable-inline/webkit-playsinline
Product: WebKit Reporter: Daniel Bates <dbates>
Component: WebCore Misc.Assignee: Daniel Bates <dbates>
Status: NEW ---    
Severity: Normal CC: aestes, commit-queue, ddkilzer, dino, eric.carlson, esprehn+autocc, glenn, gyuyoung.kim, jer.noble, macpherson, menard
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=157636
Attachments:
Description Flags
Patch sam: review-

Description Daniel Bates 2013-10-04 13:20:16 PDT
Upstream support for CSS media query -webkit-video-playable-inline and the HTML attribute webkit-playsinline.
Comment 1 Daniel Bates 2013-10-04 13:23:41 PDT
Created attachment 213396 [details]
Patch
Comment 2 WebKit Commit Bot 2013-10-04 13:25:36 PDT
Attachment 213396 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/platform/iphone-simulator/iphone/fast/media/video-inline-expected.txt', u'LayoutTests/platform/iphone-simulator/iphone/fast/media/video-inline.html', u'Source/WebCore/ChangeLog', u'Source/WebCore/css/MediaFeatureNames.h', u'Source/WebCore/css/MediaQueryEvaluator.cpp', u'Source/WebCore/html/HTMLAttributeNames.in', u'Source/WebCore/html/HTMLMediaElement.cpp', u'Source/WebCore/html/HTMLMediaElement.h', u'Source/WebKit/mac/ChangeLog', u'Source/WebKit/mac/WebView/WebPreferences.mm']" exit_code: 1
Source/WebCore/css/MediaQueryEvaluator.cpp:638:  video_playable_inlineMediaFeatureEval is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Sam Weinig 2013-10-07 11:30:00 PDT
Comment on attachment 213396 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=213396&action=review

I don't see any reason for this to iOS specific.

> Source/WebCore/css/MediaFeatureNames.h:34
> +#if PLATFORM(IOS)

This should be ENABLE(...)

> Source/WebCore/css/MediaFeatureNames.h:35
> +#define IOS_VIDEO_PLAYABLE_INLINE(macro) macro(video_playable_inline, "-webkit-video-playable-inline")

This should not have an iOS prefix.