Summary: | filter: drop-shadow doesnot support viewport units | ||||||||
---|---|---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | gur.trio | ||||||
Component: | CSS | Assignee: | gur.trio | ||||||
Status: | RESOLVED FIXED | ||||||||
Severity: | Normal | CC: | allan.jensen, commit-queue, darin, esprehn+autocc, glenn, macpherson, menard | ||||||
Priority: | P2 | ||||||||
Version: | 528+ (Nightly build) | ||||||||
Hardware: | All | ||||||||
OS: | All | ||||||||
Attachments: |
|
Description
gur.trio
2013-09-28 00:50:05 PDT
Created attachment 212883 [details]
Test case for filter: drop-shadow
Created attachment 212885 [details]
Patch
Comment on attachment 212885 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=212885&action=review > Source/WebCore/css/StyleResolver.cpp:3877 > + if (item->x->isViewportPercentageLength()) > + x = viewportPercentageValue(*item->x, x); Maybe we should have a function that does this dance. I have noticed that we have to repeat this idiom at every call site. If the inline call to isViewportPercentageLength is important for performance, we can make the function do it inline. I’d want to go back and do this for as many of the places we use viewportPercentageValue as possible. I don’t like repetitive idioms like this one when they are unnecessary. Comment on attachment 212885 [details] Patch Clearing flags on attachment: 212885 Committed r156606: <http://trac.webkit.org/changeset/156606> All reviewed patches have been landed. Closing bug. |