Bug 121504

Summary: AX: Replace AXObjectCache postNotification method boolean arguments with enum values.
Product: WebKit Reporter: Samuel White <samuel_white>
Component: AccessibilityAssignee: Samuel White <samuel_white>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, eric, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch.
cfleizach: review+
Updated patch. none

Description Samuel White 2013-09-17 10:34:29 PDT
Nearly every use of postNotification passes in a constant boolean value. Readability would improve if we replaced these booleans with enum values that were easier for reviewers to parse.
Comment 1 Samuel White 2013-09-17 10:50:39 PDT
<rdar://problem/15010675>
Comment 2 Samuel White 2013-09-23 12:43:10 PDT
Created attachment 212381 [details]
Patch.

Changing postNotification bool argument to enum per "Names" rule #10 in the WebKit coding style guidelines and reviewer feedback.
Comment 3 chris fleizach 2013-09-24 08:59:52 PDT
Comment on attachment 212381 [details]
Patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=212381&action=review

> Source/WebCore/accessibility/AXObjectCache.cpp:723
> +    if (object && (postTarget == TargetObservableParent))

extra parens here are not necessary
Comment 4 Samuel White 2013-09-24 10:18:33 PDT
Created attachment 212477 [details]
Updated patch.

Thanks for the feedback Chris. I had added the inner parens because I figured it saved people from having to do a mental lookup of operator precedence. Removed.
Comment 5 WebKit Commit Bot 2013-09-24 10:56:15 PDT
Comment on attachment 212477 [details]
Updated patch.

Clearing flags on attachment: 212477

Committed r156339: <http://trac.webkit.org/changeset/156339>
Comment 6 WebKit Commit Bot 2013-09-24 10:56:17 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Samuel White 2013-09-26 11:22:28 PDT
*** Bug 112857 has been marked as a duplicate of this bug. ***