Bug 121441

Summary: Change a couple of COMPILE_ASSERTs to static_assert
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Status: RESOLVED FIXED    
Severity: Normal CC: benjamin, cmarcelo, commit-queue
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch kling: review+

Anders Carlsson
Reported 2013-09-16 10:36:11 PDT
Change a couple of COMPILE_ASSERTs to static_assert
Attachments
Patch (6.32 KB, patch)
2013-09-16 10:36 PDT, Anders Carlsson
kling: review+
Anders Carlsson
Comment 1 2013-09-16 10:36:54 PDT
WebKit Commit Bot
Comment 2 2013-09-16 10:38:37 PDT
Attachment 211809 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WTF/ChangeLog', u'Source/WTF/wtf/BloomFilter.h', u'Source/WTF/wtf/PackedIntVector.h', u'Source/WTF/wtf/StdLibExtras.h', u'Source/WTF/wtf/StringHasher.h', u'Source/WTF/wtf/Vector.h', u'Source/WTF/wtf/text/AtomicString.cpp', u'Source/WTF/wtf/unicode/Unicode.h']" exit_code: 1 Source/WTF/wtf/StdLibExtras.h:133: bitwise_cast is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 1 in 8 files If any of these errors are false positives, please file a bug against check-webkit-style.
Andreas Kling
Comment 3 2013-09-16 10:38:55 PDT
Comment on attachment 211809 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=211809&action=review > Source/WTF/wtf/StdLibExtras.h:135 > + static_assert(sizeof(FromType) == sizeof(ToType), "bitwise_cast size of FromType and toType must be equal!"); toType -> ToType
Anders Carlsson
Comment 4 2013-09-16 10:49:33 PDT
Note You need to log in before you can comment on or make changes to this bug.