Bug 121441 - Change a couple of COMPILE_ASSERTs to static_assert
Summary: Change a couple of COMPILE_ASSERTs to static_assert
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-16 10:36 PDT by Anders Carlsson
Modified: 2013-09-16 10:49 PDT (History)
3 users (show)

See Also:


Attachments
Patch (6.32 KB, patch)
2013-09-16 10:36 PDT, Anders Carlsson
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2013-09-16 10:36:11 PDT
Change a couple of COMPILE_ASSERTs to static_assert
Comment 1 Anders Carlsson 2013-09-16 10:36:54 PDT
Created attachment 211809 [details]
Patch
Comment 2 WebKit Commit Bot 2013-09-16 10:38:37 PDT
Attachment 211809 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WTF/ChangeLog', u'Source/WTF/wtf/BloomFilter.h', u'Source/WTF/wtf/PackedIntVector.h', u'Source/WTF/wtf/StdLibExtras.h', u'Source/WTF/wtf/StringHasher.h', u'Source/WTF/wtf/Vector.h', u'Source/WTF/wtf/text/AtomicString.cpp', u'Source/WTF/wtf/unicode/Unicode.h']" exit_code: 1
Source/WTF/wtf/StdLibExtras.h:133:  bitwise_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 1 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Andreas Kling 2013-09-16 10:38:55 PDT
Comment on attachment 211809 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=211809&action=review

> Source/WTF/wtf/StdLibExtras.h:135
> +    static_assert(sizeof(FromType) == sizeof(ToType), "bitwise_cast size of FromType and toType must be equal!");

toType -> ToType
Comment 4 Anders Carlsson 2013-09-16 10:49:33 PDT
Committed r155883: <http://trac.webkit.org/changeset/155883>