Bug 120683

Summary: [Qt][WK1] REGRESSION(r154988): compositing/video/video-with-invalid-source.html fails
Product: WebKit Reporter: Zoltan Arvai <zarvai>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: andrunko, commit-queue, eric.carlson, glenn, gns, jer.noble, kadam, menard, mrobinson, pnormand
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 79666, 117354    
Attachments:
Description Flags
Patch
none
Logs LayoutTests/media and LayoutTests/http/tests/media/ against master
none
Logs LayoutTests/media and LayoutTests/http/tests/media/ against master + changeset reverted
none
Logs LayoutTests/media and LayoutTests/http/tests/media/ against master + proposed patch none

Description Zoltan Arvai 2013-09-04 08:24:25 PDT
After http://trac.webkit.org/changeset/154988 test fails with timeout.

--- /ramdisk/qt-linux-32-release-NRWT/build/layout-test-results/compositing/video/video-with-invalid-source-expected.txt
+++ /ramdisk/qt-linux-32-release-NRWT/build/layout-test-results/compositing/video/video-with-invalid-source-actual.txt
@@ -1 +1,2 @@
-PASS
+FAIL: Timed out waiting for notifyDone to be called
+
Comment 1 Zoltan Arvai 2013-09-04 08:38:32 PDT
Skipped on Qt WK1 in http://trac.webkit.org/changeset/155042.
Comment 2 Andre Moreira Magalhaes 2013-09-04 17:15:22 PDT
Created attachment 210507 [details]
Patch

Patch that should fix this regression and other media regressions on the same changeset.
Comment 3 Andre Moreira Magalhaes 2013-09-04 17:17:46 PDT
Created attachment 210511 [details]
Logs LayoutTests/media and LayoutTests/http/tests/media/ against master

run-webkit-tests logs for LayoutTests/media and LayoutTests/http/tests/media/ against master (93de7e).
Comment 4 Andre Moreira Magalhaes 2013-09-04 17:19:54 PDT
Created attachment 210516 [details]
Logs LayoutTests/media and LayoutTests/http/tests/media/ against master + changeset reverted

run-webkit-tests logs for LayoutTests/media and LayoutTests/http/tests/media/ against master (93de7e) + changeset r154988 (git commit 6ebd5a) reverted.
Comment 5 Andre Moreira Magalhaes 2013-09-04 17:21:14 PDT
Created attachment 210520 [details]
Logs LayoutTests/media and LayoutTests/http/tests/media/ against master + proposed patch

run-webkit-tests logs for LayoutTests/media and LayoutTests/http/tests/media/ against master (93de7e) + proposed patch from comment #2.
Comment 6 Andre Moreira Magalhaes 2013-09-04 17:23:53 PDT
Looks like test media/video-aspect-ratio.html should be marked as flaky, it works and fails randomly (sometimes with timeout, sometimes with failure).
Comment 7 WebKit Commit Bot 2013-09-05 00:32:38 PDT
Comment on attachment 210507 [details]
Patch

Clearing flags on attachment: 210507

Committed r155104: <http://trac.webkit.org/changeset/155104>
Comment 8 WebKit Commit Bot 2013-09-05 00:32:41 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Zoltan Arvai 2013-09-05 05:34:48 PDT
Unskipped in http://trac.webkit.org/changeset/155110.
Thanks for the fix.