Bug 120533

Summary: Implement SynchronousLoaderClient::platformBadResponseError() for !USE(CFNETWORK) platforms
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: New BugsAssignee: Csaba Osztrogonác <ossy>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap, beidson, ossy
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 108832    
Attachments:
Description Flags
workaround none

Description Csaba Osztrogonác 2013-08-30 09:40:50 PDT
SynchronousLoaderClient::platformBadResponseError() is implemented for USE(CFNETWORK) platforms only,
but used by the not guarded SynchronousLoaderClient::willSendRequest() function. It causes build
failure on !USE(CFNETWORK) platforms with enable NetworkProcess.
Comment 1 Csaba Osztrogonác 2013-08-30 09:51:20 PDT
Created attachment 210124 [details]
workaround

It is only a quick workaround to make the build happy, needs more investigation.
Comment 2 Csaba Osztrogonác 2013-09-02 02:28:44 PDT

*** This bug has been marked as a duplicate of bug 120532 ***