Bug 120148

Summary: Multiple webaudio tests flakily fail or assert because of garbage collection failures
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: Web AudioAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap, crogers, eric.carlson, ggaren, jer.noble, simon.fraser, thorton
Priority: P2 Keywords: InRadar, LayoutTestFailure
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Ryosuke Niwa 2013-08-21 21:59:38 PDT
http://webkit-test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=webaudio%2Fjavascriptaudionode-upmix2-8channel-input.html
e.g. http://build.webkit.org/results/Apple%20Lion%20Release%20WK2%20(Tests)/r154435%20(12241)/results.html

--- /Volumes/Data/slave/lion-release-tests-wk2/build/layout-test-results/webaudio/javascriptaudionode-upmix2-8channel-input-expected.txt
+++ /Volumes/Data/slave/lion-release-tests-wk2/build/layout-test-results/webaudio/javascriptaudionode-upmix2-8channel-input-actual.txt
@@ -2,7 +2,6 @@
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
-PASS onaudioprocess was called with correct input data.
 PASS successfullyParsed is true
 
 TEST COMPLETE
Comment 1 Ryosuke Niwa 2013-08-21 22:01:45 PDT
Updated the test expectation in http://trac.webkit.org/changeset/154437.
Comment 2 Alexey Proskuryakov 2013-10-07 23:11:17 PDT
Updated expectations in r157087. This is not limited to Lion, and this is a garbage collection failure that manifests in an assertion in debug builds. See also: bug 105299.

<rdar://problem/14228073>
Comment 3 Alexey Proskuryakov 2013-10-07 23:11:19 PDT
*** Bug 119459 has been marked as a duplicate of this bug. ***
Comment 4 Alexey Proskuryakov 2013-10-23 23:12:52 PDT
*** Bug 123249 has been marked as a duplicate of this bug. ***
Comment 5 Alexey Proskuryakov 2014-04-15 09:23:41 PDT
There are many tests failing for the same reason, let's track them all in one bug.

*** This bug has been marked as a duplicate of bug 112521 ***