Bug 119368

Summary: REGRESSION: Click on focused link removes focus
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: UI EventsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED WONTFIX    
Severity: Normal CC: ahmad.saleem792, ap, darin, tkent, webkit-bug-importer
Priority: P2 Keywords: BlinkMergeCandidate, InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 49977    
Bug Blocks:    
Attachments:
Description Flags
Test none

Description Ryosuke Niwa 2013-07-31 18:42:08 PDT
Merge https://chromium.googlesource.com/chromium/blink/+/71060ded1efe47f78aeb5093975242c5621a9513

This is a regression by wkrev.com/72796.

The first isMouseFocusable call in EventHandler::dispatchMouseEvent 
should be isFocusable because we need to do different things for
focusable-but-non-mouse-focusable elements.

Also fix wrong usage of isMouseFocusable in text shadow elements and
SVG elements. In general isFocusable must return true whenever
isMouseFocusable is true. Some layout tests fail without these changes.
Comment 1 Ryosuke Niwa 2013-07-31 18:42:22 PDT
What steps will reproduce the problem?
1. Open data:text/html,<input autofocus><a href="#start" onclick="return false">Link</a>
2. Press TAB key once
3. Click on the focused link

What is the expected output? What do you see instead?
Expected: The link keeps focus.
Actual: The link looses focus.

Please use labels and text to provide additional information.
Regression by http://trac.webkit.org/changeset/72796.
Comment 2 Ryosuke Niwa 2013-07-31 18:42:38 PDT
http://crbug.com/264575
Comment 3 Radar WebKit Bug Importer 2013-07-31 18:42:58 PDT
<rdar://problem/14614161>
Comment 4 Ahmad Saleem 2022-09-04 15:28:03 PDT
I think at SVG2 changed things slightly and we followed this:

https://github.com/WebKit/WebKit/commit/b84ee93b9aab347ef4152cba6622c4e16f560c30

Just sharing updated context. Thanks!
Comment 5 Ryosuke Niwa 2022-09-05 22:56:50 PDT
Created attachment 462158 [details]
Test
Comment 6 Ryosuke Niwa 2022-09-08 11:52:39 PDT
This is won't fix at this point. WebKit's focusing support has been updated numerous times since this patch was written.