Bug 49977 - Use the right focusable check to avoid multiple focus/blur events being fired from inside of the shadow DOM.
Summary: Use the right focusable check to avoid multiple focus/blur events being fired...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Dimitri Glazkov (Google)
URL:
Keywords:
: 50163 (view as bug list)
Depends on:
Blocks: 119368 46015 49982
  Show dependency treegraph
 
Reported: 2010-11-23 08:42 PST by Dimitri Glazkov (Google)
Modified: 2013-07-31 18:42 PDT (History)
2 users (show)

See Also:


Attachments
Patch (4.61 KB, patch)
2010-11-23 08:45 PST, Dimitri Glazkov (Google)
no flags Details | Formatted Diff | Diff
Patch (5.55 KB, patch)
2010-11-23 10:04 PST, Dimitri Glazkov (Google)
no flags Details | Formatted Diff | Diff
Now with working layout test (5.80 KB, patch)
2010-11-23 14:30 PST, Dimitri Glazkov (Google)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitri Glazkov (Google) 2010-11-23 08:42:30 PST
Use the right focusable check to avoid multiple focus/blur events being fired from inside of the shadow DOM.
Comment 1 Dimitri Glazkov (Google) 2010-11-23 08:45:31 PST
Created attachment 74672 [details]
Patch
Comment 2 Dimitri Glazkov (Google) 2010-11-23 10:04:45 PST
Created attachment 74678 [details]
Patch
Comment 3 Dimitri Glazkov (Google) 2010-11-23 14:30:35 PST
Created attachment 74698 [details]
Now with working layout test
Comment 4 WebKit Commit Bot 2010-11-28 22:29:02 PST
Comment on attachment 74698 [details]
Now with working layout test

Rejecting patch 74698 from commit-queue.

Failed to run "['./WebKitTools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=eseidel-cq-sl', 'build', '--no-clean', '--no-update', '--build-style=both']" exit_code: 2
Last 500 characters of output:
normal x86_64 c++ com.apple.compilers.gcc.4_2
	CompileC /Projects/CommitQueue/WebKitBuild/WebCore.build/Release/WebCore.build/Objects-normal/x86_64/SVGSVGElement.o /Projects/CommitQueue/WebCore/svg/SVGSVGElement.cpp normal x86_64 c++ com.apple.compilers.gcc.4_2
	CompileC /Projects/CommitQueue/WebKitBuild/WebCore.build/Release/WebCore.build/Objects-normal/x86_64/SVGTextQuery.o /Projects/CommitQueue/WebCore/rendering/svg/SVGTextQuery.cpp normal x86_64 c++ com.apple.compilers.gcc.4_2
(3 failures)


Full output: http://queues.webkit.org/results/6316108
Comment 5 WebKit Commit Bot 2010-11-29 07:12:57 PST
Comment on attachment 74698 [details]
Now with working layout test

Clearing flags on attachment: 74698

Committed r72796: <http://trac.webkit.org/changeset/72796>
Comment 6 WebKit Commit Bot 2010-11-29 07:13:03 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Dimitri Glazkov (Google) 2010-11-29 10:47:50 PST
*** Bug 50163 has been marked as a duplicate of this bug. ***