|Summary:||[Automake] Introduce libJSCBindings.la|
|Product:||WebKit||Reporter:||Zan Dobersek <zan>|
|Component:||New Bugs||Assignee:||Zan Dobersek <zan>|
|Severity:||Normal||CC:||cgarcia, gustavo, mrobinson|
|Version:||528+ (Nightly build)|
Description Zan Dobersek 2013-07-29 04:14:29 PDT
[Automake] Introduce libJSCBindings.la
Comment 2 Zan Dobersek 2013-07-29 04:29:03 PDT
This basically extracts what might be the JSC bindings layer into its own library.
Comment 3 Carlos Garcia Campos 2013-07-29 05:02:32 PDT
I think this is a good idea, but I find the name a bit confusing. It sounds to me like bindings for the JSC API instead of JSC DOM bindings. The GObject DOM bindings internal library is called libWebCoreDOM, which is not accurate either :-) What about libWebCoreJSDOM and libWebCoreGObjectDOM for example? This is a WebCore sub-library so I think it makes sense to have the libWebCore prefix. What do you think?
Comment 4 Zan Dobersek 2013-07-29 05:18:29 PDT
Yeah, it could use a better name: - libWebCoreJSCDOMBindings and libWebCoreGObjectDOMBindings (long, but spot-on with the description), - libJSCWebCoreDOMBindings and libGObjectWebCoreDOMBindings (again descriptive, compared to first proposal the 'JSC/GObject' part is switched with 'WebCore'), - libJSCDOMBindings and libGObjectDOMBindings (loses the 'WebCore' part, if one thinks of it as a layer that's independent of WebCore), - libJSCWebCoreBindings and libGObjectWebCoreBindings (loses the 'DOM' part, since technically. So, basically, we should use whatever we agree on being the best and most descriptive combination of strings 'JSC', 'WebCore' and 'DOM'. :>
Comment 5 Zan Dobersek 2013-07-31 09:48:21 PDT
Building with disabled WK1, WK2 and SVG and with purged ccache, there's a ~1.8% increase in compilation time with this patch applied.