Bug 117404

Summary: REGRESSION(r151339): fast/repaint/region-painting-in-composited-view.html crashing.
Product: WebKit Reporter: Gábor Ábrahám <abrhm>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: achicu, allan.jensen, hyatt, jturcotte, kadam, mihnea, zarvai
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 79668, 117270    

Description Gábor Ábrahám 2013-06-10 04:26:12 PDT
After this revision this test crash on Qt Debug and Apple Mountain Lion Debug bots.
Backtrace on Qt Debug: https://gist.github.com/abrhm/5747965

Apple Debug bot result: http://build.webkit.org/results/Apple%20MountainLion%20Debug%20WK2%20(Tests)/r151339%20(10463)/results.html 

Qt debug bot result: http://build.webkit.sed.hu/results/x86-32%20Linux%20Qt%20Debug/r151365%20(26084)/results.html

Crash log: 
crash log for DumpRenderTree (pid 2602):
STDOUT: <empty>
STDERR: ASSERTION FAILED: enclosingIntRect(rendererMappedResult) == enclosingIntRect(FloatQuad(result).boundingBox())
STDERR: /ramdisk/qt-linux-32-debug/build/Source/WebCore/rendering/RenderGeometryMap.cpp(142) : WebCore::FloatQuad WebCore::RenderGeometryMap::mapToContainer(const WebCore::FloatRect&, const WebCore::RenderLayerModelObject*) const
...
Link: http://build.webkit.sed.hu/results/x86-32%20Linux%20Qt%20Debug/r151365%20(26084)/fast/repaint/region-painting-in-composited-view-crash-log.txt


Could you check it please?
Comment 1 Mihnea Ovidenie 2013-06-10 04:49:15 PDT

*** This bug has been marked as a duplicate of bug 117395 ***